在 Proxmox VE 上使用 LXC 建置 UU 加速器

  1. 入手 Linksys WRT1900AC 作爲 AP,刷 DD-WRT 固件
  2. 闖入聯通定製烽火 HG220G-U(WO-36)
  3. 也許是最折騰的(隨身)迷你伺服器:計劃
  4. 也許是最折騰的(隨身)迷你伺服器:軟體
  5. 也許是最折騰的(隨身)迷你伺服器:裝機
  6. 在國科大(UCAS)宿舍配置 IPv6 穿透
  7. 斐訊 K3 上車,開啓 Telnet、刷已 Root 版官方固件和 Merlin
  8. 使用 bind9 建置混合 DNS(Response Policy Zone)
  9. 斐訊 K2T 開箱與動手艹(動手玩)
  10. Huawei B315s-936 4G LTE CPE 開箱與動手玩
  11. 透過 VLAN 從不同出口獲得 IPv4/IPv6 地址構建雙棧網路
  12. 關於半夜艹貓的這檔事:中興 ZTE ZXHN F677V2 ONT 設定橋接
  13. 修復 OpenWRT 上 Clash(OpenClash)影響 Port Forwarding 的問題
  14. 在 OpenWRT 上正確開啓網易 UU 加速器
  15. 在 Proxmox VE 上使用 LXC 建置 UU 加速器

網易的 UU 路由器插件支援 Merlin、小米路由器和 OpenWRT。但是如果沒有支援的路由器如何使用呢?開 VM 是最簡單的方式,先前也分享過一些技巧。容器作法也已經有現成的工作可以使用。不過在 Proxmox VE 上還可以使用 Linux 容器單獨運行 OpenWRT。

建立 LXC 容器

OpenWRT 現時已經提供了官方的 rootfs,直接下載就可以使用了。不過由於 Proxmox VE 上的 LXC 作業系統類型未有預設 OpenWRT,所以需要在命令列下建立容器:

export CTID=2000
pct create ${CTID} \
    /path/to/storage/template/cache/openwrt-21.02-amd64.tar.xz \
    --hostname openwrt-uu
    --rootfs local-lvm:1 \
    --cores 1 \
    --memory 512 \
    --arch amd64 \
    --ostype unmanaged \
    --unprivileged 0
pct set ${CTID} --net0 name=eth0,bridge=vmbr0,ip=manual

注意:由於容器後續需要使用 TUN 裝置,所以需要是特權容器--unprivileged 0)。至於其他部分則是看需求而定。

然後爲容器新增 TUN 裝置,編輯 /etc/pve/lxc/${CTID}.conf 加入以下行:

lxc.cgroup2.devices.allow: c 10:200 rwm
lxc.hook.autodev: sh -c "modprobe tun; cd ${LXC_ROOTFS_MOUNT}/dev; mkdir net; mknod net/tun c 10 200; chmod 0666 net/tun"

此時容器已經準備好,可以啓動了。

設定網路

啓動容器後,OpenWRT 預設是從 DHCP 獲得 IP 位置的,並且預設的網路介面劃定爲 WAN 區域。由於 UU 加速器需要 br-lan 接口,爲了方便後續設定,編輯 /etc/config/network 以調整 OpenWRT 的網路設定:

config interface 'loopback'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option device 'lo'
	option ifname 'lo'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option ipaddr '{{UU_LAN_IPADDR}}'
	option gateway '{{UU_LAN_GATEWAY}}'
	option netmask '{{UU_LAN_NETMASK}}'

同時編輯 /etc/config/dhcp 關閉掉接口上的 DHCP:

config dhcp 'lan'
        option interface 'lan'
        option ignore '1'
        option ra_management '0'

重新啓動容器,然後安裝 UU 路由器插件及第三方的 LuCI 管理介面:

opkg update
opkg install ca-certificates kmod-tun
opkg install uugamebooster luci-app-uugamebooster luci-i18n-uugamebooster-zh-cn

出於保險考慮,可以禁用掉防火牆之類的無關服務:

/etc/init.d/firewall disable
/etc/init.d/odhcpd disable

最後開啓 UU 加速器:

uci set uuplugin.uuplugin.enabled='1'
/etc/init.d/uuplugin enable
/etc/init.d/uuplugin start

使用 UU 加速服務

在 DHCP 伺服器上,爲遊戲主機下發特定的設定檔,將閘道器和 DNS 設定為容器的 IP。同時,在手機上的「UU 主機加速」應用程式中綁定路由器插件前,需要將手機閘道器和 DNS 也設定爲容器的 IP;綁定完畢後,可以改回原來的設定。設定完成後,打開「UU 主機加速」應用程式即可看到裝置出現,正常操作加速即可。

第三方的 LuCI 管理介面
第三方的 LuCI 管理介面

閱讀更多

發佈留言

發佈留言必須填寫的電子郵件地址不會公開。

This site uses Akismet to reduce spam. Learn how your comment data is processed.